Digital Performer™ 4.6 Update Notes

OVERVIEW
This guide provides information about new features in Digital Performer Version 4.6 that are not found in the manual.

System requirements .................................................1
Pitch automation.....................................................1
V-Racks.................................................................7
Pattern Gate plug-in...............................................9
Audio click ..........................................................10
Saving and loading plug-in user presets .....................10
Support for AU presets ..........................................11
Multiple audio outputs for AU and Rewire ...............11
Improved OMF file interchange ...............................11
Support for AAF file interchange .............................12
New Find Tempo window .......................................15
Saving audio export settings ................................16
Bounce to QuickTime Movie ..................................17
Multiple movies ....................................................18
Multiple QuickScribe windows ..............................19
Working with multiple mixes .................................19
External MIDI control for sends .........................19
Control surface support for send pan .....................19
Delay compensation under DAE .........................20
Miscellaneous enhancements ...............................20

SYSTEM REQUIREMENTS
■ Digital Performer 4.6 has been fully tested and qualified for use with Mac OS X 10.3 or higher (Panther and Tiger).
■ The minimum system required for Digital Performer 4.6 is a G4/500MHz with 512MB RAM.
■ The recommended system required for Digital Performer 4.6 is a dual-processor G4 with 1GB of RAM or more.

PITCH AUTOMATION
Digital Performer 4.6 allows you to manipulate the pitch of monophonic audio material in the form of pitch automation data that can be edited directly in the track where the audio resides. Like volume and pan, pitch automation is applied non-destructively to track output in real-time during playback.

A wide variety of pitch-related operations can be performed on audio data, from simple pitch correction using the pencil tool, to individual note transposition, to wholesale transposing of an entire track from one mode or key to another using the Transpose command. The success of these operations depends highly on the nature of the audio material itself.

Dry, monophonic audio material is required
Like Digital Performer’s other PureDSP-based, pitch-related audio processing features, pitch automation can be applied to mono, stereo and even surround audio files, and it works best on monophonic audio material — monophonic in the sense that it consists of a single instrument or voice. Chords, stacked vocals, or full mixes won’t likely produce usable results.

Pitch correction works best on audio material that has been recorded “dry” (with no effects processing). Apply delay, reverb, and similar effects after pitch automation. For example, you could place eVerb on a track containing dry, pitch-corrected audio.

PureDSP pitch analysis
Pitch automation is based on Digital Performer’s long-standing PureDSP™ processing. Therefore, if you plan to use pitch automation for pitch correction or other tasks, and you’ve disabled PureDSP’s preemptive file analysis, you will find it more convenient to re-enable background PureDSP file analysis. To do so, choose Digital Performer menu> Preferences and click the Background Processing item in the list. Consult the Digital Performer User Guide for complete details about these background processing features.

Latency compensation
Pitch automation requires Digital Performer’s latency compensation features, so be sure that the Automatic Plug-in Latency Compensation option is enabled in the Setup menu> Configure Audio System> Configure Studio Settings dialog.

Pitch automation note range
Pitch automation edits are limited to the note range C0 through C6.

Pitch edits are bound to soundbites
Even though they look just like volume, pan and other track-based automation data types, pitch automation edits are bound to the specific soundbite on which you perform the edit. This means that if you then move the soundbite, the pitch edits move with it. In addition, all instances of the soundbite in the project are affected. Conversely, you can create harmonies from the same source audio by creating different soundbites from the same parent audio file region. Each separate soundbite can have unique pitch edits.

Pitch adjustments are non-destructive
Any adjustments that you make to the pitch of audio are non-destructive and non-destructive. In other words, the original audio data is not modified in any way, nor is any new audio data generated on disk. Instead, pitch modifications are rendered in real-time by Digital Performer’s PureDSP engine. Therefore, they can be quickly applied, modified and removed, even during playback. In fact, you might find it most useful to keep playback going — and even loop sections — when you are editing pitch, as you will enjoy the benefit of instant feedback as you work. Pitch
corrections can, however, be permanently applied to audio by merging the soundbite or (unlike other forms of automation) exporting the soundbite.

**Viewing pitch automation**
To access pitch automation, choose Pitch from the Sequence Editor track layer menu (Figure 1). The pitch layer represents the pitch of the audio in two forms, superimposed on top of the waveform: 1) as a blue line (the pitch curve) and 2) as bars or pitch segments. Both are measured by the pitch ruler along the left edge of the track. You can expand the vertical size of the track, zoom the vertical resolution and scroll the vertical position of the pitch layer information, all independently of the waveform display. This allows you, for example, to position the pitch information above or below the actual waveform, rather than directly on top of it.

**The pitch curve**
The blue pitch curve (Figure 1) represents the original pitch, as detected by PureDSP. If you modify the pitch curve in any way, the modified portions of the curve are displayed in red. You can select and edit the pitch curve directly using the arrow tool and the pencil tool, as follows:

<table>
<thead>
<tr>
<th>To do this to the pitch curve</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>To add a control point</td>
<td>Double-click the pitch curve with the arrow tool.</td>
</tr>
<tr>
<td>To modify the pitch curve</td>
<td>Drag the control point with the arrow tool.</td>
</tr>
<tr>
<td>To anchor the pitch curve</td>
<td>Add control points on either side of it at the locations where you want to anchor the curve.</td>
</tr>
<tr>
<td>To select a control point</td>
<td>Drag over it with the arrow tool (lasso cursor).</td>
</tr>
<tr>
<td>To delete a control point</td>
<td>Select the portion of the pitch curve and choose Audio menu&gt; Audio Pitch Correction&gt; Clear Pitch Control Points.</td>
</tr>
</tbody>
</table>

**Pitch curve control points**
Control points can be added to the pitch curve to modify it as follows:

<table>
<thead>
<tr>
<th>To do this to the pitch curve</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>To redraw the pitch curve</td>
<td>Set the Pencil/Reshape curve menu in the Tool Bar to Free and drag over the pitch curve with the pencil tool.</td>
</tr>
<tr>
<td>To select the pitch curve</td>
<td>Drag over it with the arrow tool (lasso cursor), or click a pitch segment to select the part of the curve that it represents.</td>
</tr>
<tr>
<td>To get rid of any red portions (modifications)</td>
<td>Select the curve and hit delete, or choose Audio menu&gt; Audio Pitch Correction&gt; Clear Pitch.</td>
</tr>
<tr>
<td>To scale the existing curve</td>
<td>Option-click the curve and then drag vertically. See &quot;Scaling the pitch curve&quot; below for further details.</td>
</tr>
<tr>
<td>To reshape the curve</td>
<td>Choose the desired shape from the Pencil/Reshape curve menu in the Tool Bar, set the edit grid resolution (if desired) and drag over the pitch curve with the pencil tool.</td>
</tr>
</tbody>
</table>

**For best results**
Although you can make precise pitch corrections on the pitch curve with the pencil tool and control points, often you will achieve more natural results by simply transposing and scaling the original curve as described in the following sections.

**Scaling the pitch curve**
Option-drag vertically on the pitch curve to scale it. Dragging upwards accentuates the existing curve, while dragging down flattens it. The portion of the curve that is affected by the scaling operation is determined by:
the end points of the pitch segment at the location where you click, or

- the currently selected portion of the pitch curve, if any.

You can also scale the pitch curve by selecting the portion you wish to scale and choosing Audio menu > Audio Pitch Correction > Scale Expression.

Scaling the pitch curve can be used for a variety of applications. Here are a few examples:

- To produce more or less vibrato in audio that already has some vibrato
- To reduce unwanted variations in pitch
- To enhance variations in pitch

Pitch segments

Pitch segments (Figure 1) represent the detected average root pitch of each note in the audio. They are displayed in the color assigned to the track. These segments can be fine-tuned in a variety of ways to accurately represent individual notes in the audio — without changing the audio itself. You can then use the pitch segments to modify the pitch of the audio in a wide variety of ways, from micro-tonal tuning adjustments to wholesale transposition and key changes. You can even copy and paste pitch segments into a MIDI track to create MIDI notes that match the source audio.

Fine-tuning pitch segments

Pitch segments are most useful when they accurately represent the pitch and duration of each individual note in the audio. PureDSP does its best to detect the root pitch, beginning and end of each note. But further adjustment may be necessary. For example, a singer may bend the pitch of a held note, causing PureDSP to represent the audio as two different pitch segments. To accurately represent them as one continuous segment, you can go in by hand to merge them together into a single pitch segment. As another example, you might want to slightly adjust where the transition from one segment to another occurs.

Fine-tuning pitch segments does not affect audio

It is crucial to understand that the types of changes to the pitch segments being discussed so far have no effect whatsoever on the audio signal itself. Instead, the purpose of these changes is to represent as accurately as possible the notes in the original audio signal itself. The more accurate the pitch segment representation, the more successfully you will be able to modify the pitch of the audio using the pitch segments (via several techniques discussed later).

Setting the pitch mode

Before you make individual adjustments to pitch segments, you should first choose an overall pitch mode for the audio. There are two different pitch modes: vocals and instruments. Choosing the appropriate pitch mode for the audio material you are working with can dramatically improve PureDSP’s initial representation of the pitch segments, so that you’ll have much less tweaking to do by hand, if any. To set the pitch mode for a track or soundbite, select it and then choose Audio menu > Audio Pitch Correction, and then choose the desired sub-menu command:

![Figure 4: Setting the pitch mode for a soundbite or track.](image)

Here is a summary of how these three pitch mode commands affect pitch segments:

<table>
<thead>
<tr>
<th>Pitch mode command</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Track Pitch Mode</td>
<td>Sets the default pitch mode for any audio material newly recorded into that track. It does NOT affect existing soundbites already in the track, or soundbites dragged into the track.</td>
</tr>
<tr>
<td>Set Pitch Mode for Selected Bites</td>
<td>Sets the pitch mode and modifies the pitch segments accordingly for the currently selected audio in the Soundbites window or in any tracks.</td>
</tr>
<tr>
<td>Set Pitch Mode for Track and Selected Bites</td>
<td>Applies the pitch mode to both the track and any currently selected soundbites as described above in one operation.</td>
</tr>
</tbody>
</table>

Adjusting pitch segmentation

Another way to control overall pitch segmentation accuracy is to select the desired audio and then choose Audio menu > Audio Pitch Correction > Adjust Pitch Segmentation:

![Figure 5: Adjust Pitch Segmentation.](image)

Move the slider to the right for more detailed segmentation; move it left for less detail. The Instruments and Vocals settings along the slider match their corresponding menu settings shown in Figure 4 on page 3 and produce the same results and the respective menu setting.
Adjusting pitch segments while playing back
It can help to loop a section and make pitch segment adjustments during playback to match what you are seeing with what you are hearing. This goes for all pitch segment editing.

Editing pitch segments
Once you've chosen the pitch mode for the track or soundbite, you can further modify the pitch segments to more accurately reflect the notes in the audio as follows:

<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>To join adjacent segments</td>
<td>Click between them with the Mute tool.</td>
<td><img src="before-after.png" alt="Example" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="before-after.png" alt="Example" /></td>
</tr>
<tr>
<td>To split adjacent segments</td>
<td>Click with the scissor tool.</td>
<td><img src="before-after.png" alt="Example" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="before-after.png" alt="Example" /></td>
</tr>
<tr>
<td>To move the boundary between two segments</td>
<td>Drag one of the adjacent segment edges with the arrow tool (using the trim cursor shown below)</td>
<td><img src="before-after.png" alt="Example" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="before-after.png" alt="Example" /></td>
</tr>
</tbody>
</table>

Trimming pitch segments
As noted above, you can position the arrow tool over the edge of a pitch segment to get the trim cursor (shown in the table). Drag horizontally with the trim cursor to move the edge of the segment. If the pitch segment you are trimming lies adjacent to silence (at the beginning or end of the audio signal), you are not allowed to extend the segment into the silence, as segments only represent portions of the soundbite that have audio signal of some kind.

Gray pitch segments
Gray pitch segments represent portions of the audio signal that have no detectable pitch. For example, a percussive drum sound, such as a cymbal, has no clearly defined root pitch. Another example are the sibilants found in vocal tracks: these are sounds such as “s” or “ch” that do not have pitch to them.

Dangling segments
A dangling segment is a portion of a segment for which there is no pitch curve. This is most often the result of unpitched material that is not yet split into its own gray segment. In the example below, the dangling segment on the left has been split into a gray segment using the scissor and trim tools. There may be situations, however, where dangling segments are preferred, such as when you convert pitch segments into MIDI notes (“Converting audio pitch to MIDI data” on page 6).

Reverting to the default pitch segmentation
If you edit the pitch segments and then decide you want to start over, select the soundbite and choose Audio menu > Audio Pitch Correction > Set Pitch Mode for Selected Bites > and then choose either vocals or instruments. Doing so recomputes the pitch segments and restores them to their original state, before any modifications.
Modifying pitch using pitch segments

Once the pitch segments accurately reflect the notes in the audio, as explained in the previous sections, you can use the pitch segments to transpose the audio as follows:

<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>To transpose a note chromatically</td>
<td>Drag its pitch segment vertically. The note snaps to the root pitches in the pitch ruler, but also maintains its relative position to the root pitch (if it’s a little sharp or flat).</td>
</tr>
<tr>
<td>To correct the pitch slightly or perform other micro-tonal adjustments</td>
<td>Command-drag the pitch segment vertically.</td>
</tr>
<tr>
<td>To select the pitch segment (and the portion of the pitch curve that it represents)</td>
<td>Click the pitch segment with the arrow (finger) tool.</td>
</tr>
<tr>
<td>To select multiple pitch segments</td>
<td>Shift-click them or drag over them with the arrow (lasso) tool.</td>
</tr>
<tr>
<td>To drag multiple pitch segments</td>
<td>Select them first and then drag them.</td>
</tr>
<tr>
<td>To return a pitch segment to its original pitch</td>
<td>Select it and hit delete, or choose Audio menu &gt; Audio Pitch Correction &gt; Clear Pitch.</td>
</tr>
</tbody>
</table>

When you modify pitch segments, the pitch curve reflects those changes. In fact, the pitch segments are essentially “note-bound” handles for the pitch curve itself, so when you edit the segments, you are really editing the pitch curve. The segments merely provide a musical way to manipulate the curve, including smooth pitch transitions between notes when transposing individual notes.

Quantizing pitch

If you would like to “center” one or more pitch segments, so that they are tuned exactly to their relative root pitch (to fix any notes that are a little sharp or flat), select their pitch segments and choose Audio menu > Audio Pitch Correction > Quantize Pitch. Doing so centers each pitch segment with its corresponding root pitch in the pitch ruler. In general, you achieve best results from this operation if you first edit pitch segments with the mute and scissor tools, as explained in “Editing pitch segments” on page 4.

Transposing audio

You can use Digital Performer’s standard Transpose command (Region menu) to apply a wide variety of transpose operations on the pitch segments and the audio data they represent. Select the pitch segments you wish to transpose (using any of the techniques discussed in the previous section) — or just select the audio itself — and choose Region menu > Transpose. Make sure the Transpose audio check box is checked, and the Transpose audio by adjusting pitch automation option is chosen, as demonstrated in Figure 11 below:

Figure 11: Check the 'Transpose audio' check box to transpose audio data.

You can then choose any form of transposition option you wish, including Interval, Diatonic, Key/Scale and even Custom Map. This is a very powerful feature because it gives you the same level of complete control when transposing audio as you do when transposing MIDI data. Keep in mind, however, that the success of audio transposition operations like this, as with all PureDSP pitch-shifting, depends on the size of the intervals involved and the nature of the audio material being transposed. Some types of audio material transpose better than others.

Another important factor for successful transposition is the accuracy with which the pitch segments in the pitch layer of the track represent the actual notes in the audio, as explained in the previous sections. So before using the Transpose command to transpose audio, it is a good idea to spend some time reviewing the pitch segments for accuracy.

In the example above (Figure 11), audio is being transposed from one key and mode (C minor) to an entirely different key and mode (D Phrygian).

Transposing audio and MIDI together

When using the Transpose command (Figure 11), you can of course select both audio and MIDI tracks together to transpose them in one operation. Just be sure to check both the MIDI and audio check boxes as shown in Figure 11.
**Temporarily disabling pitch modifications**

Any modifications you make to the pitch of audio in the Pitch Layer of an audio track can be temporarily disabled using the techniques described below. When you disable pitch modification in this way, all pitch edits are fully preserved, and you can re-enable them at any time:

<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>To temporarily disable all pitch modifications in the entire track</td>
<td>Click the ‘P’ button at the bottom of the track’s pitch ruler in the Sequence Editor. You can also use DP’s option-click and command-click shortcuts. Or choose Bypass Pitch from the track settings menu.</td>
</tr>
<tr>
<td>To temporarily disable a specific soundbite’s pitch modifications</td>
<td>In the Soundbite window info pane, set the soundbite’s Transpose attribute to Don’t Pitch Shift.</td>
</tr>
</tbody>
</table>

When pitch edits are disabled, you cannot edit the track pitch layer information.

When pitch automation is bypassed using the ‘P’ button, the data is still processed in real-time so that you can immediately hear the results when you unbypass. In this case, the bypassed pitch automation takes up just as much computer processing resources as when it is unbypassed (playing).

When pitch automation is bypassed via the Don’t Pitch Shift soundbite setting, the pitch data is completely ignored, therefore conserving your computer’s processing resources.

**Converting audio pitch to MIDI data**

Pitch segments (Figure 1) can be copied and pasted into MIDI tracks, essentially allowing you to convert the pitch information in the audio into MIDI data. This powerful feature can be used for a wide variety of applications. For example, you could layer a vocal part with MIDI parts, or sing a melody and then convert it to MIDI data for further development. The possibilities are endless.

The accuracy of the MIDI transcription is entirely dependent on the accuracy with which the pitch segments represent the notes in the audio. The more accurately the pitch segments represent the actual audio, the more accurate the MIDI transcription.

**Preparing for MIDI pitch transcription**

Pitch segments are copied and pasted as is, so if you have made any modifications to the pitch segments — or changes to the pitch curve that are reflected by the pitch segments — the changes will be carried over into the MIDI track.

For best results, try these preparations on the pitch segments before you copy and paste them:

- Make sure there is a one-to-one correspondence between each pitch segment and each note that you hear in the audio.
- Review the timing of the pitch segments — where they start and end — to accurately reflect the full duration of each note.

While these preparations will help a lot, it is important that you realize that the resulting MIDI notes will not match the pitch segments exactly. See “What you see is not what you’ll necessarily get” below.

**Copying and pasting pitch segments**

After making the preparations listed above, copy and paste pitch segments as follows. This procedure assumes that you want the resulting MIDI notes to play in time with the original audio, so you will be pasting the MIDI data at the location where the first pitch segment begins:

1. Select the pitch segments with the arrow tool (lasso cursor).
2. Choose Copy from the Edit menu.
3. To paste the resulting MIDI notes so that they play in time with the original audio, leave the pitch segments selected and choose Set to Selection Bounds from the Selection Pane menu in the Control panel as shown below in Figure 12.

4. Click the name of the MIDI track you wish to paste into to create a time range selection in the destination track that matches the current selection start time (which now matches the start time of the first pitch segment you copied).
5. Choose Paste from the Edit menu.

**What you see is not what you’ll necessarily get**

When you copy pitch segments and paste them into a MIDI track, the resulting MIDI notes will likely not exactly match the original pitch segments. This is because Digital Performer interprets the pitch segments with respect to the waveform to create a MIDI performance that matches the audio as closely as possible.

To further refine the timing of the resulting MIDI notes, try quantizing them. Best results are often achieved by quantizing both attacks and releases of the MIDI notes.

**Formant-corrected vs. standard pitch shifting**

In the Soundbite info pane, each soundbite can be configured for either PureDSP (formant-corrected) pitch shifting or standard pitch shifting. This setting affects real-time pitch automation. If you wish to preserve the original character of the sound, such as
for harmonizing or pitch correction, use the (default) PureDSP setting. For special pitch effects, experiment with standard pitch shifting.

Figure 13: Pitch automation can be applied as formant-corrected (PureDSP) or standard pitch shifting via the ‘Transpose’ soundbite setting.

V-RACKS

V-Racks™ (virtual racks) are a new type of chunk in Digital Performer. They are similar to regular sequences, but they are streamlined as follows:

- They have no time domain.
- They do not hold track data or automation.
- The only types of tracks that you can add are: Instrument tracks, aux tracks and master faders.
- They do not have a Tracks Window, Sequence Editor or any other type of edit window. The only window that can be opened to modify them is the Mixing Board.
- They cannot be placed in a song.

V-Racks have several significant characteristics that make them very useful:

- They are always active, regardless of what sequence or song is play-enabled.
- Their track inputs and outputs are always available to all other sequences in the project.
- They provide all of the real-time processing capabilities of a regular sequence, including the ability to host virtual instruments.

A virtual effects and instrument rack

When you add up all of the above characteristics, essentially what you have is a virtual effects and instrument rack — hence the name V-Rack. V-Racks are ideal in situations where you are using multiple sequences in a project, as the following examples illustrate.

Virtual instruments

A very common situation is as follows: you have a project with multiple sequences that are all playing the same virtual instrument. For example, you might be working on a TV commercial with several sequences in the project: a :15 second version, a :30 second version and a :60 second version. But they are all playing essentially the same sounds loaded into MachFive. To work most efficiently, you can load one instance of MachFive into a V-Rack, and then access MachFive from any of the other sequences, just as if it were loaded into each sequence individually. By loading it only once in the V-Rack, you save memory and computer processing resources. Samples and patches will not need to reload when switching among sequences.

In earlier versions of Digital Performer, you would need to load one instance of MachFive into each separate sequence, and load the same samples into each instance — a much less efficient use of your computer's memory and processing resources.

Mastering

Another very common situation is this: you have multiple sequences that you want to master using the same mastering effects chain. To ensure consistency and to maximize efficiency, you can add a master fader track to a V-Rack, apply the desired effects processing and then run the master output of each individual sequence into the master fader in the V-Rack. Regardless of which sequence is play enabled, the V-Rack master fader settings can be applied. Not only do you conserve your computer's processing resources (since you only have to create one instance of the effects), you also ensure that each individual sequence is processed with exactly the same plug-in settings in your mastering chain.

Effects loops

A another common situation is this: you have multiple sequences and you wish to use the same effect in all of them as a send/return loop. For example, suppose all your sequences contain voice-overs that you would like to process through identical compression and reverb. To once again ensure consistency and simplify the setup of this loop across all sequences, you can add an aux track to the V-Rack and then add the desired effects chain plug-ins to it. Set the input to be a bus, and its output to be the main outs (or another bus, for added flexibility). Now, all tracks in any sequence assigned to that effect bus will receive identical effect processing.

Live effects processing

A final example for V-Racks is this: you are performing music in a live context, and you would like to have an effects chain set up that is always active, regardless of what sequence is playing back. You could set up an aux track in a V-Rack from a physical input on your audio hardware to a physical output, and add whatever processing you would like. Now Digital Performer can perform as a virtual effects rack, no matter which sequence is play enabled.

Creating a V-Rack

You can add any number of V-Racks to a Digital Performer project in any of the following ways:

- Choose Project menu> Sequences> Add V-Rack
- Choose Add V-Rack from the Chunks window mini-menu.
- Choose New V-Rack from the Sequences mini-menu in the Control Panel, Tracks Overview or Sequence Editor.
Click the V-Rack button in the title bar of the Mixing Board or the Effects window. If a V-Rack does not yet exist in your project, one is added.

**V-Rack quick reference (Figure 14)**

**Move handle:** Drag this handle vertically to change its position in the list. Note: unlike track sequences and song, you cannot place a V-Rack into a song, or drag it anywhere else. This handle is for repositioning it in the list only.

**Enable/Disable:** Brings the V-Rack on line (active and processing audio) or offline (inactive).

**Working with a V-Rack**

V-Racks are viewed via the Mixing Board. Open the Mixing Board for the V-Rack using any of the standard techniques for accessing the Mixing Board for a sequence.

For example, in the Consolidated Window, go to the Mixing Board and then choose the desired V-Rack from the sequences menu, as demonstrated below:

Adding tracks to a V-Rack

Once you have opened the Mixing Board for the V-Rack (and it is the active window or cell), you can then add aux tracks, instrument tracks and master faders to it using any of the standard techniques for adding tracks to a sequence. For example, you could choose *Project menu > Add Track.*

Moving tracks from a sequence to a V-Rack

If you would like to move an aux track, master fader or instrument track from a regular sequence to a V-Rack:

1. Make sure the source sequence is play-enabled.
2. Select the track(s) you wish to move.
3. Choose *Move Selected Tracks to V-Rack* from the Sequence menu in the Control Panel (as shown below in Figure 16), Tracks Window or Sequence Editor.

Moving tracks from a sequence to a V-Rack:

1. Make sure the source sequence is play-enabled.
2. Select the track(s) you wish to move.
3. Choose *Move Selected Tracks to V-Rack* from the Sequence menu in the Control Panel (as shown below in Figure 16), Tracks Window or Sequence Editor.
4. Choose the desired destination V-Rack from the resulting dialog.

The track disappears from the source sequence and is moved to the destination V-Rack.

Deleting tracks from a V-Rack

To delete tracks from a V-Rack, choose *Delete Track* from the pop-up menu at the bottom of each mixer-strip in the Mixing Board.

The V-Rack button

The V-Rack (V) button in the Mixing Board title bar (and the Effects window title bar) toggles between the currently play-enabled sequence and the last viewed V-Rack.
**Master fader priority**
Digital Performer now allows you to assign two or more master faders to the same output pair. But only one can be active at a time. Therefore, master fader priority is determined similarly to voice (disk) tracks that share the same voice: by their top-to-bottom order in Chunks window list and, within a V-Rack, their left-to-right order in the Mixing Board.

Master Fader tracks in sequences that are higher in the chunk list take priority over Master Fader tracks farther down the list.

Similarly, within a given sequence or V-Rack, Master Fader tracks that are higher in the track list (or further to the left in a V-Rack Mixing Board) take priority over ones farther down (or to the right).

Here’s an example: suppose that you have a multiple-sequence project where most sequences share a single “global” mastering V-Rack. However, one sequence’s sonic characteristics are different enough that it requires completely different master stage processing, while still sending its final output to the same output pair as all the other sequences.

In this situation, you could add a master fader directly in the sequence, assign it to the same outputs as the mastering V-Rack, but then place it above the V-Rack in the Chunks window list. When you then make it the play-enabled sequence, its master fader becomes the active (priority) master fader for the output pair. When you play-enable any of the other sequences, the V-Rack master fader becomes active.

In essence, this setup provides a “default” mastering channel, while also allowing “override” mastering channels as needed for individual sequences.

**PATTERN GATE PLUG-IN**
The Pattern Gate (Figure 19) slices up the audio signal passing through it into pulses determined by the Speed menu, which displays metric divisions locked to the tempo of the sequence.

The pattern gate can be applied to just about any sound that sustains. Remember, however, that the tempo of the sequence plays an important role in the results.

**Pulse shape**
The shape of each pulse is determined by the Pulse Shape graph (Figure 19), which represents 100% of the length of each pulse. Drag the handles to modify pulse Depth, Attack, Sustain and Decay. Or edit the numeric values below the graph. Drag the Depth handle vertically to soften the gate, such as for a tremolo effect.

**Pattern and Length**
The pattern itself is determined by the Pattern LED strip (Figure 19): click each pulse to toggle it on or off. Set the Length of the pattern (from 1-16 pulses) by dragging the Length handle.

**Pattern Gate LFO**
The Pattern Gate LFO (Figure 19) can be used to modulate the four pulse shape parameters (Depth, Attack, Sustain and Decay). Choose the desired LFO waveform (sine, sawtooth or rectangle) from the menu provided and set the desired Symmetry between 0 and 100, where 50 is normal symmetry. Then choose the desired Period, which is expressed in a number of pattern gate steps. The range is 0-256 steps. For example, if you choose a period of 110 steps, then the LFO will complete one cycle in 110 pattern gate steps.

Once you’ve set up the Pattern Gate as desired, apply it to the desired pulse shape parameters using the LFO menus below each parameter. The range for the LFO setting is -100 to +100, where zero applies no LFO effect at all. +100 modulates the setting from...
its current value all the way to the maximum possible setting. -100 modulates the setting from its current value all the way to the minimum possible setting.

**Swing**
When the Swing parameter (Figure 19) is set to zero, the pattern gate plays in straight time (no swing). Other settings are as follows:

<table>
<thead>
<tr>
<th>Swing amount</th>
<th>Ratio</th>
<th>Feel at 8th note speed</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1:1</td>
<td>Straight 8ths</td>
</tr>
<tr>
<td>100</td>
<td>2:1</td>
<td>Triplet 8ths</td>
</tr>
<tr>
<td>125</td>
<td>2.5:1</td>
<td>Hard 8th swing</td>
</tr>
<tr>
<td>150</td>
<td>3:1</td>
<td>Hard 8th shuffle</td>
</tr>
</tbody>
</table>

Negative values invert the ratio, which moves the swung note closer to the base note.

**AUDIO CLICK**
Digital Performer now provides an audio click that plays back with sample-accurate precision. You can assign the click to play on any available audio output bundle in your system. A variety of preset click sounds are provided, and you can add an unlimited number of your own custom click sounds. You can play the audio output to any available audio output bundle.

---

**Audio output**
Choose the desired audio output bundle for the click sound from the menu provided.

**Click sounds**
Choose the desired accented and normal click sounds from the menus provided (Figure 22). A variety of preset sounds are provided, including the ubiquitous Urei metronome click sound. Or you can use any compatible audio file you wish using the Choose File menu item.

**Audio click volume control**
Use the Master Volume slider (Figure 20) to control the overall volume of both the accented and normal clicks. Use the individual volume knobs to the right of each click sound menu to adjust their volume relative to each other.

**Adding your own click sounds**
To add your own clicks to the click sound menus, save them as a mono SDII or AIFF audio file, give the file the name you wish to see in the menu, and then drop it into the Clicks folder in the Digital Performer application folder. You can add as many click sounds as you wish.

**Disabling the audio click**
To disable the audio click, choose None from the audio click output menu.
SAVING AND LOADING PLUG-IN USER PRESETS
User plug-in presets are now saved independently from Digital Performer documents or the Digital Performer application itself. Instead, they are now stored as preset files on disk in the following location:

/Library/Audio/Presets/Digital Performer/

Figure 23: Plug-in presets are now stored independently as preset documents.

Saving plug-in user presets
To save a user plug-in preset, make the settings in the plug-in as desired and then choose Save Settings from the Effects window mini-menu. You can save the settings anywhere you wish on disk, but if you would like them to appear in the User Presets sub-menu (Figure 24), save them in the plug-in’s presets folder. For example, the chorus presets shown above in Figure 23 are stored here:

/Library/Audio/Presets/Digital Performer/Chorus

Loading plug-in user presets
To load a user preset, choose it from the User Presets sub-menu in the plug-in’s mini-menu:

Figure 24: The new User Presets sub-menu.

Like clippings, user presets can also be dragged and dropped from the Mac OS X desktop (Figure 23) directly to inserts in the Mixing Board.

SUPPORT FOR AU PRESETS
Some Audio Unit plug-ins have the ability to save presets as a standard AU preset file on disk. Digital Performer now supports these AU preset files. You can save them and load them as described in “Saving and loading plug-in user presets” on page 11, including the ability to drag and drop them to inserts in the Mixing Board.

MULTIPLE AUDIO OUTPUTS FOR AU AND REWIRE
Some audio unit (AU) plug-ins and Rewire-compatible applications provide multiple audio outputs. You can now access them in the new Instruments tab in the Audio Bundles window as shown in Figure 25.

Creating instrument output bundles
To make the Audio Unit or Rewire application’s outputs appear across the top of the Audio Bundles window, instantiate the AU instrument plug-in, or launch Reason (or other Rewire application), as usual. Then use the Add button at the bottom of the window to create as many bundles as needed in the usual fashion: choose the desired channel format, specify a name, and place the tiles on the desired channels.

Using instrument output bundles
Instrument output bundles operate just like a bus: they can be used to route audio from the instrument to any other destination within Digital Performer's powerful mixing environment. For example, you could route the instrument’s output to an aux track, or even the input of a V-Rack (as explained in “V-Racks” on page 7).

IMPROVED OMF FILE INTERCHANGE
Many enhancements and improvements have been made to Digital Performer’s ability to import and export OMF sessions for interchange with other OMF-compliant applications. In addition, more options have been added for exporting OMF files. For details, see “OMF/AAF Export Options” on page 13.
**SUPPORT FOR AAF FILE INTERCHANGE**

Digital Performer now has the ability to import and export AAF 1.0 session files for interchange with Pro Tools 6 and other AAF-compliant applications. You should be able to exchange both AAF and OMF sessions with any application that supports AAF (1.0 and 1.1) or OMF 1.0 or 2.0 session interchange. Digital Performer’s implementation has been mostly tested with Pro Tools, Logic Pro, Avid Express and Final Cut Pro.

**Exporting an AAF file**

To export an AAF file, choose Save As or Save a Copy As from the File menu, and then choose AAF Interchange from the Format menu (Figure 26). The OMF/AAF Export Options window appears (Figure 27).

**Figure 26:** Digital Performer can now import and export AAF files.

**Figure 27:** The OMF/AAF Export Options.

**Figure 25:** The Instruments tab in the Audio Bundles window provides access to multiple outputs from Audio Units and Rewire applications.
OMF/AAF Export Options

Pro Tools has varying degrees of OMF and AAF interchange support, depending on the version. For example, older versions of Pro Tools only support DigiTranslator 1.0 OMF files, but newer versions support DigiTranslator 2.0 files. Similarly, other applications that support OMF and AAF interchange also have varying degrees of support for these interchange file formats. As a result, Digital Performer provides numerous interchange options to give you the broadest possible compatibility across the board. Here is a brief explanation of the OMF/AAF export options shown in Figure 27.

The ‘Enforce Compatibility’ options

The Enforce options at the top of the window basically enable or disable various options below so that you won’t inadvertently enable an option that is not supported by the third-party application. For example, DigiTranslator 1.0 does not support clip-based volume or pan; therefore, when you chose the Enforce OMFTool/DigiTranslator 1.0 compatibility check box at the top of the window, the Export clip-based volume check box at the bottom of the window becomes grayed out (unavailable).

As another example, Logic Pro (as of Version 7.0) does not support AAF files with embedded audio data. Therefore, if you check the Enforce Logic compatibility check box at the top of the window, and you are exporting an AAF file, the Embed audio data in OMF/AAF file option below becomes grayed out.

Export references to sound files

The Export references to sound files option is only available for OMF export; it is grayed out if you’ve chosen to export to AAF. It is also grayed out if you’ve chosen the Quantize edits to frame boundaries option, which requires you to use the Consolidate sound files option.

Choose Export references to sound files if you want the OMF or AAF file to refer to the same set of audio files on disk as the Digital Performer project that you are exporting from. This option saves disk space because it does not duplicate audio data. Because the Digital Performer Project and OMF/AAF file refer to the same set of audio, use this option when you are making permanent (“destructive”) changes to the audio data in the audio files that you would like to be reflected in both Digital Performer and Pro Tools. For example, you might be removing clicks and pops, normalizing, etc.

There are some situations in which some audio data is copied. For example, if Digital Performer needs to convert from 24-bit audio to 16-bit audio, it will have to copy audio. Also, fade files (when using Export fades as precomputed regions) always get copied.

Copy all sound files

The Copy all sound files option is grayed out if you’ve chosen the Quantize edits to frame boundaries option, which requires you to use the Consolidate sound files option (explained in the next section).

Choose Copy all sound files to make a completely self-contained copy of the entire project, including all audio files and fades. All audio files that are listed in the Soundbites window are included, even if they are not used in any tracks in the project. This option is ideal for transferring the project to another hard drive or computer as it ensures that all associated audio files are “collected” and included in the interchange document. When you use this option, the exported project will have no references to your original project. This makes it completely independent, and it will not be affected by any changes made to the original project.

Consolidate sound files

Like Copy all sound files above, the Consolidate sound files option leaves no references to the original project and instead copies the original audio. However, it only copies audio that is actually used in soundbites. Portions of audio files that fall outside of soundbite boundaries are not copied. This option is useful because it can save a significant amount of disk space in some projects. If you are looking to economize on the project size, perhaps for archival purposes, this option is a good choice.

The Handle Size option specifies the amount of extra audio (in milliseconds) to include before and after each soundbite. This is useful if you will be trimming (edge editing) the soundbites in Pro Tools or other destination application.

Embed audio data in OMF/AAF file

This option applies to audio being copied during the export operation, if any.

Choose Embed all audio data in OMF/AAF file to place the copied audio directly into the OMF or AAF file itself. This makes a single, completely self-contained document that consists of a copy of the entire project, including all audio files and fades. See “Copy all sound files” on page 13 and “Consolidate sound files” on page 13 for further information about what audio gets copied and when this option is useful.

The current versions of DigiTranslator and Logic Pro don’t support embedded audio for AAF files (although they do for OMF), so this option will be disabled if those compatibility check boxes are enabled (in the AAF export dialog only).

Export audio data as Sound Designer II/AIFF/WAVE files

These options apply to audio being copied during the export operation, if any. Choose the desired file format for the audio files being copied to the AAF or OM file project.

The Sound Designer II file option is disabled (not available) when you are exporting to an AAF file because AAF files do not support Sound Designer II files.

‘Export fades as’ options

The Export fades as OMF/AAF effects option produces fades and crossfades that can be fully modified in Pro Tools after the transfer, if desired. The Export fades as precomputed regions option “prints” each fade as an audio region, preserving the exact...
nature of the fade or crossfade as it was programmed in Digital Performer but rendering it un-modifiable in Pro Tools. For example, if you like the way your fades and crossfades sound already in Digital Performer, and do not need to further modify them in Pro Tools, use this option.

If you've chosen the Quantize edits to frame boundaries option, then the Export fades as OMF/AAF effects option is not available (grayed out).

**Exporting 24-bit audio**
If the Enforce OMFTool/DigiTranslator 1.0 compatibility option is checked, the Export 24 bit audio directly option is grayed out because OMF 1.0 does not support 24 bit audio. The Convert 24 bit audio to 16 bits option converts all 24-bit audio in the project to 16-bit audio. DigiTranslator 2.0 supports 24-bit audio, as do most other third-party audio applications, so if you are exporting 24-bit audio and wish to maintain this bit depth, choose Export 24 bit audio directly.

**Export sample-accurate edits/Quantize edits to frame boundaries**
For Avid Xpress and other applications that require OMF/AAF files to specify all timing in SMPTE time code frames, choose Quantize edits to frame boundaries. Digital Performer's current frame rate setting (Setup menu > Frame Rate) is used. This frame rate setting must match the frame rate in the Avid Xpress session into which you will import the OMF/AAF file. Also, when using the Quantize edits to frame boundaries option, then you are forced to use the Consolidate Sound Files and Export fades as precomputed regions options. All of your soundbites will get trimmed so that they start and end on frame boundaries. To maintain timing and ensure that all audio is properly included, Digital Performer then generates one-frame audio regions placed before and after the trimmed soundbite, containing the audio that was trimmed.

For all other applications (that don’t require frame-based timing), choose Export sample-accurate edits. Consult the documentation for your editing application to determine if it requires frame-based timing for audio.

**Export clip-based volume/pan**
Because the OMF and AAF interchange formats support a clip-based automation model, automation data between clips is lost when exporting, but automation data within the boundaries of every audio region is preserved during transfers.

The Export clip-based volume and Export clip-based pan options determine whether volume and/or pan automation data will be included in the resulting OMF or AAF interchange document.

If the Enforce OMFTool/DigiTranslator 1.0 compatibility option is checked, these options are grayed out because the OMF 1.0 file format does not support them.

If the Enforce OMFTool/DigiTranslator 2.0 compatibility or Enforce Logic compatibility options are checked, then the Export clip-based pan option is grayed out because DigiTranslator and Logic do not support pan automation interchange via OMF or AAF.

**Export original time stamps**
Check the Export original time stamps option to include the original time stamps in each audio file. If your destination application does not support them, you can turn them off. For a complete explanation of time stamps, refer to the Digital Performer User Guide. This option is not available when Enforce OMFTool/DigiTranslator 1.0 compatibility is enabled.

**Export soundbite names**
Check the Export soundbite names option to export each audio region with its given soundbite name in Digital Performer. This option is not available when Enforce Logic compatibility is enabled.

**Export all sequences**
If the Digital Performer project you are exporting has two or more sequences, check the Export all sequences option if you wish to include all sequences, even the ones that are not currently play-enabled. This option is grayed out if you are enforcing any compatibility at the top of the window, except for Avid Express.

**Export all takes**
If the tracks in the sequences you are exporting have multiple takes, check the Export all takes option if you wish to include them in the export operation. Each take is saved in the OMF/AAF export document as a separate track.

**OMF/AAF export summary**
Here is a summary of OMF and AAF export:

<table>
<thead>
<tr>
<th>OMF/AAF export option</th>
<th>Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>When exporting AAF</td>
<td>Disables Export references to sound files  \ Disables Export audio data as SDII files</td>
</tr>
<tr>
<td>OMFTool/DigiTranslator 1.0 compatibility check box</td>
<td>AAF only: Disable Embed audio data… \ Requires Convert 24 bit audio to 16 bits \ Disables Export clip-based volume \ Disables Export original time stamps \ Disables Export all sequences \ Disables Export all takes</td>
</tr>
<tr>
<td>DigiTranslator 2.0 compatibility</td>
<td>AAF only: Disable Embed audio data… \ Disables Export clip-based pan \ Disables Export all sequences \ Disables Export all takes</td>
</tr>
<tr>
<td>Logic compatibility</td>
<td>AAF only: Disable Embed audio data… \ Disables Export clip-based pan \ Disables Export soundbite names \ Disables Export all sequences \ Disables Export all takes</td>
</tr>
<tr>
<td>Avid Xpress compatibility</td>
<td>Requires Quantize edits to frame boundaries</td>
</tr>
<tr>
<td>Quantize edits to frame boundaries</td>
<td>Requires Consolidate sound files \ Requires Export fades as precomputed regions</td>
</tr>
</tbody>
</table>
NEW FIND TEMPO WINDOW
The Find Tempo window (Figure 28) has been reworked from the ground up to provide the most advanced tempo searching capabilities available. This window helps you quickly find tempos that best match the hits (locked markers) in your sequence (film or video cue).

Start Bar
Use the Start Bar (Figure 28) to enter a measure|beat|tick where you want to start the tempo search. Applied tempos will be inserted at this point in the sequence. Click the Start button as a shortcut for entering the current counter time in the start field.

Tempo Range settings
The Tempo Range settings (Figure 28) operate as explained in the Digital Performer User Guide, except that the BPM (Beats Per Minute) note value for the tempo is independent of the resolution setting for the grid you are searching on.

Search Grid
The Search Grid note value menu (Figure 28) lets you set the beat resolution grid on which you would like to search for hits. Because this is now separate from the tempo specification, you can search, for example, for quarter note tempos but evaluate hits according to the closest eighth note.

Chunk Selector
The Chunk Selector (Figure 28) lets you choose which cue (sequence) you are searching in, as in previous versions of DP. However, it now also displays the start time of the chunk following the selector popup (displaying timecode bits as 80ths of a frame). This chunk start time will immediately update if you choose to apply a tempo with an offset, to show you what effect the offset had on the chunk start time. This saves you from having to go to the Chunks window mini-menu to open the Set Chunk Start dialog, just to verify what happened to the chunk start time.

Offset
The Offset settings (Figure 28) allow you to specify how much of an offset (in frames) you wish to consider from the chunk’s current SMPTE start time, and how many different offsets to check. The offset settings shown in the example in Figure 28 would check the results of every tempo with offsets ranging between –3 and 3 frames. The Step setting specifies how many offsets to check between the minimum and maximum frame numbers. The Step setting in Figure 28 will test offsets at intervals of one frame. Therefore, the set of offsets that will be considered is { -3, -2, -1, 0, 1, 2, 3 }.
Search button
The Find Tempo window automatically re-calculates the tempo search results whenever a search parameter changes. But if you want to manually force DP to re-calculate the tempo search results for some reason, click the Search button (Figure 28).

Max Hits
The Max Hits (Figure 28) indicator is a static text readout that tells you how many searchable markers you have (the maximum possible number of hits). This is a convenient reference for evaluating the number of hits and near hits. For example, if you get 10 hits, you’ll know that you got 10 out of 100. The Max Hits indicator counts only those markers that occur after the search start time.

Offset column
The Offset column (Figure 28) replaces the Seq Start Frame column in earlier versions of Digital Performer. It shows you the offset (in frames and 80ths of a frame) that is associated with the tempo for this search result. A search result is the combination of a tempo and an offset. If you apply a tempo, its offset (if non-zero) will be added to the current chunk start time.

Negative offsets
Offsets can be either positive or negative, although negative offsets are limited so they can never shift the chunk start time to a value that is less than zero.

Partial frame offsets
Partial frame offsets are explicitly shown, rather than hidden (as in previous versions of Digital Performer). If you click the Tempo column heading to sort the results list by tempo, then each tempo is shown with all of its possible offsets before the next tempo is shown.

Hit / Near / Miss column
The Hit/Near/Miss column (Figure 28) replaces the Total Hits column in earlier versions of Digital Performer. This column now shows three numbers: the number of hits, the number of markers that are within 1 frame of being a hit, and the number of misses. This is valuable information for honing in on tempo choices, and you can conveniently compare these numbers with the total possible number of hits (Max Hits) displayed just above this column. If you click the heading of the Hit/Near/Miss column to sort the tempo results list, it orders the results first by number of hits, and secondly by number of near misses.

Additional Find Tempo enhancements
- If you’ve chosen to include a locked marker in your search that occurs at or before the sequence start frame, offsets cannot be applied. As a result, you will see a red warning message at the top of the Find Tempo dialog that warns you that a locked marker at or before the sequence start time prevents use of offsets.
- It is no longer necessary to place a locked marker at the location where you wish to begin a tempo search. You can now enter a start measure/beat/tick in the Start field (Figure 28) directly in the Find Tempo window.
- In the Markers window, you can now drag across multiple markers in the Lock and Find columns to enable them in one gesture. (Reminder: only locked markers can be checked in the Find Tempo column.)
- The Skew column in the Markers window has been removed. Instead, you now specify a number of frames in the Hit Range Before and Hit Range After columns for each marker. These fields can be set globally for all selected markers by using Set Hit Range… in the Markers window mini-menu.

SAVING AUDIO EXPORT SETTINGS
Digital Performer 4.6 lets you save your customized, frequently used audio export settings. You can then conveniently recall them as a user preset when bouncing to disk or exporting audio.

Creating an audio export preset
To create and save an audio export preset, check the Save Settings as Audio Export Format option in the Bounce to Disk dialog (Figure 33 on page 18) or the Export Selected Bites dialog (from the Soundbites window mini-menu) and then proceed with the...
bounce or export. If there are any additional settings required, they will appear in subsequent dialogs. Then, you'll be asked to name your export preset:

**Figure 30: Saving an export preset.**

**Using an audio export preset**

Your new audio export preset now appears in all audio export format menus in Digital Performer, including the Bounce to Disk dialog and the audio export dialog. To use it, simply choose it from the menu when bouncing or exporting. These presets are saved as a preference, so they are not project-specific. They are global to all projects.

**Figure 31: Export presets appear in the format menu in the Bounce to Disk dialog and the audio export dialog.**

**Editing audio export presets**

To rename or get rid of audio export presets, choose Audio menu> Bounce Settings> Edit Audio Export Formats:

![Edit Audio Export Format](image)

**Figure 32: Editing audio export presets.**

**BOUNCE TO QUICKTIME MOVIE**

You can now bounce an audio output bundle (mono, stereo or any surround format), together with video, to a QuickTime movie file. This allows you to export a complete QuickTime movie from Digital Performer in one easy operation, complete with a sound track that you've created in DP. To do so:

1. Open a project that has a sequence with a QuickTime movie.

2. Assign the audio tracks you wish to include in the movie to the same audio output bundle. It can be any channel format, from mono to 10.2 surround.

3. Select the audio tracks over the range you wish to bounce in the usual fashion.

See the Digital Performer User Guide for complete information about using the Bounce to Disk feature.

4. Choose Audio menu> Bounce to Disk.

5. Choose QuickTime Export: Movie from the Format menu.
6 Choose the appropriate output bundle from the Source menu, and specify a destination folder as usual.

7 Click OK.

The QuickTime export options appear.

8 Specify the desired bit depth and sample rate.

9 If you wish to replace the existing movie, check the Overwrite existing file option.

10 Set the Include video options as desired. See the following section for details.

11 Click OK.

Including video
If you wish to include video in the resulting exported movie (instead of exporting only the audio), check the Include video box. If you would like to reference the original source video data in this new exported movie (to conserve disk space, for example), choose Reference original video data. If you would like to duplicate the original video data in the new exported movie, making it a complete, self-contained movie of its own, choose Duplicate original video data.

If the audio starts before the source video begins or extends past where the source video ends, choose Extend video tracks with black frames to append the movie with video black so that the resulting movie matches the length of the audio. If you would prefer white video instead, uncheck this option.

Bouncing surround audio
When bouncing a surround output audio bundle, audio tracks are named and tagged in the QuickTime movie according to the proper channel assignments. They play back optimally from the QuickTime file under both Panther and Tiger. This works regardless of how the channels are mapped to outputs in the Audio Bundles window.

MULTIPLE MOVIES
You can now open a separate movie window for each sequence in a project. To open a separate movie for each sequence:

1 Play-enable a sequence in the Chunks window.

2 Choose Project menu> Movie to open a movie for it.

3 Play-enable a different sequence in the Chunks window.

The movie window for the first sequence disappears at this point.

4 Choose Project menu> Movie to open a movie for the second sequence.

5 Repeat this procedure for as many sequences as you wish.

When you switch from one sequence to another (by clicking its play-enable button in the Chunks window), the movie window will update itself to show the movie you chose for that sequence. Each sequence also stores a separate location for the movie window on the screen. So you can reserve a different spot on screen for each movie. Or you can place them all in the same location, if you wish.

Using one movie for multiple sequences
If you wish to use only one movie for multiple sequences in a Digital Performer project, just like in previous versions of Digital Performer, there is a checkable menu item in the in the Movie Window mini-menu called Use Same Movie for All Sequences. This menu item also appears in the movie track menu in the Sequence Editor. When this menu item is checked, you get the following behavior:
■ Every sequence in the project uses the same movie.
■ Each sequence can have its own unique sequence start time, but the movie start time is the same for all sequences. Changing the sequence start time will make the movie begin earlier or later in the sequence.
■ The movie window is placed at the same position and size for every sequence.
■ Closing the movie window closes it for all sequences.
■ Choosing a new movie for one sequence chooses that same movie for all sequences.

MULTIPLE QUICKSCRIBE WINDOWS
There is now a separate QuickScribe window for each sequence in a project. For example, if you have three sequences, you could open three separate QuickScribe windows all at once, one for each sequence. To do so, you must first pop them out of the Consolidated window. To do so:

1. Click the QuickScribble tab in the Consolidated Window to view the QuickScribble cell.

If QuickScribble is the only cell in the center portion of the Consolidated Window at this point, the QuickScribble cell title bar will not yet have a “pop out” button.

2. Drag down the horizontal window divider to create a second horizontal cell in the center portion of the Consolidated Window.

You’ll now see a pop-out button in the QuickScribble cell title bar.

3. Click the QuickScribble cell’s pop-out button.

The QuickScribble window is now a separate window.

4. Play-enable the next sequence in the Chunks list and repeat this procedure to extract its QuickScribble window from the Consolidated window.

If you keep the QuickScribble window inside the Consolidated window, then there is only one QuickScribble cell that simply updates to display the currently play-enabled sequence.

WORKING WITH MULTIPLE MIXES
Digital Performer’s Mix Mode menu in the Mixing Board (to the left of the horizontal scroll bar in the lower left corner of the window) lets you create, save, edit and switch between multiple mixdowns of your project. For example, you could create several completely different mixes of the same sequence. A mix consists of all the volume, pan, plug-in and other mix automation data in all the tracks of the sequence, as well as all of the current plug-ins inserted on tracks.

This feature has been enhanced to include the following initial track settings (regardless of whether there is currently any automation data in the track):

■ Track volume
■ Pan
■ Send levels
■ Send mute states
■ Track automation mode
■ Track play-enable/disable state

By adding these track attributes to each saved mixdown, the Mix Mode menu now provides complete independence among separate mixes, even if they don’t have any automation data in them. For example, you could simply set initial volume and pan settings for each track, create a mix, duplicate it, adjust the faders and then switch back and forth between the two mixes. You can then freely switch between them, comparing the fader settings, without the need to insert or print any automation data. In general, you will find it much easier to create and use multiple mixdowns with this feature.

EXTERNAL MIDI CONTROL FOR SENDS
You can now use the Attach MIDI Controller mini-menu item in the Mixing Board to assign external MIDI control to send level knobs, send pan, and send mute buttons in the Mixing Board. To do so:

1. Activate the send by choosing an assignment from the send’s menu.

This step is required before you can assign external MIDI control.

2. Choose Attach MIDI Controller from the Mixing Board mini-menu.

3. Click the desired send control (volume, pan or mute).

You’ll see a flashing red box around the control item you have chosen.

4. Send MIDI data from your controller device.

CONTROL SURFACE SUPPORT FOR SEND PAN
It is now possible to control send panning from control surface devices like the SAC-2.2 and Mackie Control Universal.

Mackie Control Universal
To access send-pan, enter into the Soft menu (press the top left button in the Assignment section) and select SndPan.

SAC-2.2
To access send-pan, press both the Send (x) button and the Pan button simultaneously. Both will illuminate. Now the v-pots control send-pan. Pressing Pan puts you back in Send Gain mode.

HUI
Accessing send-pan works the same as the SAC 2.2, as explained above.
DELAY COMPENSATION UNDER DAE

Digital Performer’s delay (latency) compensation feature has been improved when operating under DAE with Pro Tools|HD and MIX systems. There are two steps necessary to enable Digital Performer’s Automatic Delay Compensation when running under DAE:

1. Choose the delay compensation engine you wish to use in the Setup Menu> Configure Audio System> Other DAE Settings window:

<table>
<thead>
<tr>
<th>Delay compensation option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short Engine</td>
<td>Use this setting if the greatest total latency of any of your channel strips is less than 1023 samples.</td>
</tr>
<tr>
<td>Long Engine</td>
<td>Use this setting if the total latency of any of your channel strips is greater than 1023 samples.</td>
</tr>
</tbody>
</table>

2. Make sure that Bypass Latency Compensation is disabled in the Setup> Configure Audio System menu.

Bypass Latency Compensation
This option bypasses Digital Performer’s automatic delay compensation without turning it off completely and releasing the DSP used for latency compensation. Instead, it bypasses the engine so that you do not experience any issues when recording. If you wish to release the DSP being used by latency compensation, set the Delay Compensation Engine to None in the Other DAE Settings window.

MISCELLANEOUS ENHANCEMENTS

- Initiating playback after a record pass is now much more responsive, even if beat, tempo, and pitch analysis are running. Additionally, entering play or record with tracks record-enabled is much faster, particularly on slow hard drives.
- Instrument tracks now support RTAS instruments. So you can now open an RTAS instrument via an instrument track, instead of an aux track when running under DAE.
- You can now use the VST-RTAS wrapper from FXpansion™ when running Digital Performer under DAE.
- A Jumbo option has been added to the movie track’s Size sub menu. If the movie image height is currently set to one of the four preset sizes, a check mark appears next to that setting in the Size submenu. If the track height has been dragged to a size that is in between the preset settings, none of them are check marked.
- In the Markers window, you can now drag across multiple markers in the Lock and Find columns to enable them in one gesture. (Reminder: only locked markers can be checked in the Find Tempo column.)
- QuickScribe used to auto scroll vertically only if the wiper went completely out of sight on the page. This meant that it would not auto scroll if only the top few pixels of the next system were visible. Now it auto scrolls vertically whenever it is possible to show more of the next system.
- The appearance of automation curves in the Graphic Editors has been improved; the lines are now anti-aliased for a smoother appearance.
- Crossfade computations are now faster, especially in situations where there are many crossfades to compute at one time (such as when using the Smooth Audio Edits command in the Audio menu).
- The Audio Bundles window now has a Delete Unused button that removes all unused audio bundles from the list currently being displayed in the window (as determined by the tabs at the top of the window).
- You can now delete tracks directly from the Mixing Board by choosing Delete Track from the settings menu at the bottom of each channel strip in the Mixing Board, as shown in Figure 17 on page 8.
- Several larger sizes have been added to the track size menu in the Sequence Editor: Jumbo, Huge and Immense.

![Figure 35: New vertical track sizes in the Sequence Editor.](image-url)
Tempo analysis in Digital Performer 4.6 is now between 3 and 10 times faster than version 4.52, depending on the audio material.